summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 23:04:13 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:23 +0200
commit5a32a345db7cc9f09fcbc1be22f6f5c9cca25c55 (patch)
treee7b967aa5f17f2520b4342811a2cff3417a55272
parent6d187271eddacb3e583df805b0be041988928678 (diff)
downloadguix-5a32a345db7cc9f09fcbc1be22f6f5c9cca25c55.tar.gz
gnu: Add texlive-autosp-bin.
* gnu/packages/tex.scm (texlive-autosp-bin): New variable.
(texlive-autosp)[propagated-inputs]: Add TEXLIVE-AUTOSP-BIN.

Change-Id: I60f82f3bc10bc9dc29a7e56859eb537a58bc6cac
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cf5d2f9bf3..583f26c78d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4203,6 +4203,7 @@ computer-generated long formulae with many terms.")
               "16szmbffp9pwzv7zq3l4yvnsfk4m7w57wib7pqpgv1v5fzhlaahs")))
     (outputs '("out" "doc"))
     (build-system texlive-build-system)
+    (propagated-inputs (list texlive-autosp-bin))
     (home-page "https://ctan.org/pkg/autosp")
     (synopsis
      "Preprocessor generating note-spacing commands for MusiXTeX scores")
@@ -4216,6 +4217,53 @@ concern for note-spacing changes within the part or spacing requirements of
 other parts.")
     (license license:gpl2+)))
 
+(define-public texlive-autosp-bin
+  (package
+    (inherit texlive-bin)
+    (name "texlive-autosp-bin")
+    (source
+     (origin
+       (inherit texlive-source)
+       (modules '((guix build utils)
+                  (ice-9 ftw)))
+       (snippet
+        #~(let ((delete-other-directories
+                 (lambda (root dirs)
+                   (with-directory-excursion root
+                     (for-each
+                      delete-file-recursively
+                      (scandir "."
+                               (lambda (file)
+                                 (and (not (member file (append '("." "..") dirs)))
+                                      (eq? 'directory (stat:type (stat file)))))))))))
+            (delete-other-directories "libs" '())
+            (delete-other-directories "utils" '("autosp"))
+            (delete-other-directories "texk" '())))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-bin)
+       ((#:configure-flags flags)
+        #~(cons "--enable-autosp" (delete "--enable-web2c" #$flags)))
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (with-directory-excursion "utils/autosp"
+                    (invoke "make" "check")))))
+            (replace 'install
+              (lambda* (#:key inputs native-inputs #:allow-other-keys)
+                (with-directory-excursion "utils/autosp"
+                  (invoke "make" "install"))))))))
+    (native-inputs '())
+    (inputs '())
+    (propagated-inputs '())
+    (home-page (package-home-page texlive-autosp))
+    (synopsis "Binaries for @code{texlive-autosp}")
+    (description
+     "This package provides binaries for @code{texlive-autosp}.")
+    (license (package-license texlive-autosp))))
+
+
 (define-public texlive-axodraw2
   (package
     (name "texlive-axodraw2")