summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:01:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:17 -0400
commit5afc4b537e70ad969f9e240a51c0cefab2db91cc (patch)
tree1fb25550e3f490f97f1f4951e1b02af09bf9f53a
parent9d9855f6b839d2cba9e537a06255c15656f4059f (diff)
downloadguix-5afc4b537e70ad969f9e240a51c0cefab2db91cc.tar.gz
gnu: Remove python2-couleur.
* gnu/packages/python-xyz.scm (python2-couleur): Delete variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3025300a8e..b831c864d1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20272,32 +20272,6 @@ while only declaring the test-specific fields.")
 (define-public python2-sure
   (package-with-python2 python-sure))
 
-(define-public python2-couleur
-  ;; This package does not seem to support python3 at all, hence,
-  ;; only the python2 variant definition is provided.
-  (package
-    (name "python2-couleur")
-    (version "0.6.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "couleur" version))
-       (sha256
-        (base32
-         "1qqaxyqz74wvid0cr119dhcwz0h0if5b5by44zl49pd5z65v58k1"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2))
-    (home-page "https://github.com/gabrielfalcao/couleur")
-    (synopsis
-     "ANSI terminal tool for python, colored shell and other handy fancy features")
-    (description
-     "@code{Couleur} provides python programs a way to use the ANSI features in a unix
-     terminal such as coloured output in the shell, overwriting output, indentation, etc.")
-    ;; README.md says ASL2.0, but all source code headers are LGPL3+.
-    ;; https://github.com/gabrielfalcao/couleur/issues/11
-    (license license:lgpl3+)))
-
 (define-public python-misaka
   (package
     (name "python-misaka")