summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-30 17:18:39 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-14 15:11:46 -0400
commit5c3727ff078aa345abfdd7c755a4255c2c8454bc (patch)
treedc9d186ffe78645dc781ada06044e21b3abd6c11
parent00d84146f3f724337840cf7a55bade6b01119c54 (diff)
downloadguix-5c3727ff078aa345abfdd7c755a4255c2c8454bc.tar.gz
gnu: ruby-puma: Do not install mkmf.log file.
* gnu/packages/ruby.scm (ruby-puma) [arguments]: Add delete-mkmf.log phase.
-rw-r--r--gnu/packages/ruby.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7ea88b4067..1bf2db17cc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11572,6 +11572,12 @@ part of the Prawn PDF generator.")
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
                 (invoke "bundle" "exec" "rake" "test"))))
+          (add-after 'install 'delete-mkmf.log
+            (lambda _
+              ;; Rubygems installs build log files that embed volatile file
+              ;; names (see:
+              ;; https://github.com/rubygems/rubygems/issues/6259).
+              (for-each delete-file (find-files #$output "^mkmf\\.log$"))))
           (add-before 'check 'disable-problematic-tests
             (lambda _
               (let-syntax ((skip-tests