summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:45:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:49 +0100
commit5eb7bb7c2c4d70a397e6c724f6ea750f67515b2c (patch)
tree7ddce1f9bf18b3743b88df51eadf26de78e03146
parent0fc1ce6f4f7c2987525addb8cba022d0b0830e99 (diff)
downloadguix-5eb7bb7c2c4d70a397e6c724f6ea750f67515b2c.tar.gz
gnu: go-github-com-miekg-dns: Update to 1.1.62.
* gnu/packages/golang-xyz.scm (go-github-com-miekg-dns): Update to 1.1.62.
[arguments] <#:phases>: Add 'disable-failing-tests.

Change-Id: I857df6a1520e0e08f7255b700ffc2ac1494b27db
-rw-r--r--gnu/packages/golang-xyz.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 987cdff495..0be25d8bc9 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4408,7 +4408,7 @@ colored strings.")
 (define-public go-github-com-miekg-dns
   (package
     (name "go-github-com-miekg-dns")
-    (version "1.1.48")
+    (version "1.1.62")
     (source
      (origin
        (method git-fetch)
@@ -4417,9 +4417,19 @@ colored strings.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "14m4wnbgmc1prj4ds1fsz1nwb1awaq365lhbp8clzsidxmhjf3hl"))))
+        (base32 "0wdsacp4ay6ji72vnszq6ksn5n060z2hv94wgjsn0pr7gpa3nk6c"))))
     (build-system go-build-system)
-    (arguments '(#:import-path "github.com/miekg/dns"))
+    (arguments
+     (list
+      #:import-path "github.com/miekg/dns"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-failing-tests
+            (lambda* (#:key tests? import-path #:allow-other-keys)
+              (with-directory-excursion (string-append "src/" import-path)
+                (substitute* (find-files "." "\\_test.go$")
+                  ;; Unable to run test server.
+                  (("TestIsPacketConn") "OffTestIsPacketConn"))))))))
     (propagated-inputs
      (list go-golang-org-x-tools
            go-golang-org-x-sys