summary refs log tree commit diff
diff options
context:
space:
mode:
authorTaiju HIGASHI <higashi@taiju.info>2022-02-03 15:23:02 +0900
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-02-05 23:57:48 +0100
commit5f628d773b57dd4a7b12301273669bb39a43f79e (patch)
treee793fcce330743de794956b657fe86b2237ba5c0
parent6ac6a7e0202e536b42756413d464f98e0c02f5c1 (diff)
downloadguix-5f628d773b57dd4a7b12301273669bb39a43f79e.tar.gz
gnu: poppler: Add poppler-data.
In order to make poppler support CJK and Cyrillic scripts, one of the
following has to be done:
1. Build poppler with poppler-data as input.
2. Add poppler-data into poppler's output path.
A simple union-build is not enough, as reported in
<https://issues.guix.gnu.org/53536>.

* gnu/packages/pdf.scm (poppler)[inputs]: Add poppler-data.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/pdf.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index c79d941b20..d1c672f7dc 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -242,6 +242,7 @@ please install the @code{flyer-composer-gui} package.")))
              ("libtiff" ,libtiff)
              ("lcms" ,lcms)
              ("openjpeg" ,openjpeg)
+             ("poppler-data", poppler-data)
              ("zlib" ,zlib)
 
              ;; To build poppler-glib (as needed by Evince), we need Cairo and