summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-13 11:49:32 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-30 10:11:20 +0100
commit61e70aa4992700b373f6d965d1c7aa6610ef57fd (patch)
tree5dd19433da1c12d1f58a24220121a0f19dc27d5c
parent6ecdc437e2c5c1e597ba86e4a4a2812e62fb84ab (diff)
downloadguix-61e70aa4992700b373f6d965d1c7aa6610ef57fd.tar.gz
gnu: Add python-statmorph.
* gnu/packages/astronomy.scm (python-statmorph): New variable.

Change-Id: Ie1d71e17f46bdb85c7c109f25b55bbb3b72af08c
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4e8ebc3830..7dbb95f788 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3304,6 +3304,33 @@ spherical polygons that represent arbitrary regions of the sky.")
     ;; QD_LIBRARY_LICENSE.rst for bandeled QD source
     (license license:bsd-3)))
 
+(define-public python-statmorph
+  (package
+    (name "python-statmorph")
+    (version "0.5.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "statmorph" version))
+       (sha256
+        (base32 "06rbwrqlvdzn9innx05kjjmm4mmacd8kwwsfdf5idbwzby5ny5lw"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-astropy
+           python-numpy
+           python-photutils
+           python-scikit-image
+           python-scipy))
+    (native-inputs
+     (list python-pytest))
+    (home-page "https://github.com/vrodgom/statmorph")
+    (synopsis "Non-parametric morphological diagnostics of galaxy images")
+    (description
+     "The package @code{statmorph} implements functionality of calculating
+non-parametric morphological diagnostics of galaxy images (e.g., Gini-M_{20}
+and CAS statistics), as well as fitting 2D Sérsic profiles.")
+    (license license:bsd-3)))
+
 (define-public python-stsci-image
   (package
     (name "python-stsci-image")