summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-17 22:12:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-30 10:11:20 +0100
commit64566a599e3c2bf9da2a40d6c621e1b597f0b41d (patch)
tree97e979c7aea5171014e6148113311e9ed506ea23
parent2541171580395bc14010e5ad136c321d34077ce3 (diff)
downloadguix-64566a599e3c2bf9da2a40d6c621e1b597f0b41d.tar.gz
gnu: Add python-jwst-reffiles.
* gnu/packages/astronomy.scm (python-jwst-reffiles): New variable.

Change-Id: I6c8f80e0b26109c31c610d242a364db0ac9a66a5
-rw-r--r--gnu/packages/astronomy.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c6f69d2e03..2ce0d66894 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4225,6 +4225,47 @@ science corrections sequentially, producing both fully-calibrated individual
 exposures and high-level data products (mosaics, extracted spectra, etc.).")
     (license license:bsd-3)))
 
+(define-public python-jwst-reffiles
+  (package
+    (name "python-jwst-reffiles")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jwst_reffiles" version))
+       (sha256
+        (base32 "1dlw955cw49qczdmimglmlcbal8vd3wbv5j48ckllvjgd59pwr3s"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; FIXME: Invistigate why it failes on python-jwst side where the
+      ;; python-tweakwcs is built just fine:
+      ;;
+      ;; <...>/tweakwcs/matchutils.py:18: in <module>
+      ;; from stsci.stimage import xyxymatch
+      ;; E   ModuleNotFoundError: No module named 'stsci.stimage'
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'sanity-check))))
+    (propagated-inputs
+     (list python-astropy
+           python-jwst
+           python-matplotlib
+           python-numpy
+           python-scipy))
+    (native-inputs
+     (list python-pytest
+           python-stsci-stimage))
+    (home-page "https://github.com/spacetelescope/jwst_reffiles")
+    (synopsis "Tool for JWST's CRDS-formatted reference files creation")
+    (description
+     "This package provides a tool to create @acronym{Calibration References
+Data System,CRDS}-formatted reference files for @acronym{James Webb Space
+Telescope,JWST} from a set of input dark current files and a set of flat field
+files.")
+    (license license:bsd-3)))
+
 (define-public python-pyerfa
   (package
     (name "python-pyerfa")