summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2016-05-24 12:47:49 -0400
committerDavid Thompson <dthompson2@worcester.edu>2016-05-26 08:50:09 -0400
commit6b0686fa9350cad5aa5cd85abd6721f4c12cc0ba (patch)
treea092650fb3977388697a2bd164c6d2f5a7d2a974
parent70458ed510d8bae5b5bd50e2aabf607b20198cf4 (diff)
downloadguix-6b0686fa9350cad5aa5cd85abd6721f4c12cc0ba.tar.gz
gnu: Add autoconf-archive.
* gnu/packages/autotools.scm (autoconf-archive): New variable.
-rw-r--r--gnu/packages/autotools.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index ddc628d005..de7f1f6d15 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 David Thompson <davet@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -159,6 +160,27 @@ exec ~a --no-auto-compile \"$0\" \"$@\"
                 port)))
            (chmod (string-append bin "/autoconf") #o555)))))))
 
+(define-public autoconf-archive
+  (package
+    (name "autoconf-archive")
+    (version "2016.03.20")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/autoconf-archive/autoconf-archive-"
+                          version ".tar.xz"))
+      (sha256
+       (base32
+        "0dz4fnc723jqn3by22ds5fys7g31apzm1r9allldvva0yvzjxyw8"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.gnu.org/software/autoconf-archive")
+    (synopsis "Collection of freely reusable Autoconf macros")
+    (description
+     "Autoconf Archive is a collection of over 450 new macros for Autoconf,
+greatly expanding the domain of its functionality.  These macros have been
+contributed as free software by the community.")
+    (license gpl3+)))
+
 (define-public autobuild
   (package
     (name "autobuild")