summary refs log tree commit diff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-11 21:54:56 +0100
committerMathieu Othacehe <othacehe@gnu.org>2024-01-17 11:17:59 +0100
commit6c34d33cde04a75ce4874ea037afcb20af4673be (patch)
treec30356af4d3aaced7421ac0b5933bee9eebdf37f
parent1e0b80b9e15d1d89eb2e10b7e62afaed4bbd77f8 (diff)
downloadguix-6c34d33cde04a75ce4874ea037afcb20af4673be.tar.gz
gnu: Add python-typeguard-4.
* gnu/packages/python-xyz.scm (python-typeguard-4): New variable.

Change-Id: Ic5728766e8171dc31a82056f55a8c00680db5870
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e0d74bb4e2..aebbae1521 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25318,6 +25318,24 @@ based on the CPython 2.7 and 3.7 parsers.")
 with PEP 484 argument (and return) type annotations.")
     (license license:expat)))
 
+(define-public python-typeguard-4
+  (package
+    (inherit python-typeguard)
+    (name "python-typeguard")
+    ;; This is the latest version we can use, because python-typeguard >=
+    ;; 4.0.1 requires python-typing-extensions >= 4.7.0.
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "typeguard" version))
+       (sha256
+        (base32 "11yrc7pv2fajmicwiyc92sb5gphlw3zbxww8f2prrsh6rgdv6kqr"))))
+    (build-system pyproject-build-system)
+    (arguments
+     '())
+    (propagated-inputs (list python-typing-extensions))))
+
 (define-public bpython
   (package
     (name "bpython")