summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:30:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:21 +0200
commit6ceeb9e8a67cf10bc5c0568e26427a658fe5289e (patch)
treea9c3b8cebe6c2c2c9dac47b37026f89f712b579d
parent3231a226f289ae964e7eeb7243da9baabb3e4501 (diff)
downloadguix-6ceeb9e8a67cf10bc5c0568e26427a658fe5289e.tar.gz
gnu: Add texlive-libertinus-type1.
* gnu/packages/tex.scm (texlive-libertinus-type1): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 44abbf9541..3fc2a963d6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16487,6 +16487,30 @@ The Libertinus fonts are similiar to Libertine and Biolinum, but come with
 math symbols.")
     (license license:lppl1.3+)))
 
+(define-public texlive-libertinus-type1
+  (package
+    (name "texlive-libertinus-type1")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/libertinus-type1/"
+                   "fonts/enc/dvips/libertinus-type1/"
+                   "fonts/map/dvips/libertinus-type1/"
+                   "fonts/tfm/public/libertinus-type1/"
+                   "fonts/type1/public/libertinus-type1/"
+                   "fonts/vf/public/libertinus-type1/"
+                   "tex/latex/libertinus-type1/")
+             (base32
+              "1vzvli3sbyxdsqzb3qk03mbl0qg4q7ihipddd1n6bdbjriv67zz6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/libertinus-type1")
+    (synopsis "Support for using Libertinus fonts with LaTeX")
+    (description
+     "This package provides support for use of Libertinus fonts with
+traditional processing engines (LaTeX with Dvips or Dvipdfmx, or pdfLaTeX).")
+    (license (list license:gpl2 license:silofl1.1 license:lppl))))
+
 (define-public texlive-lie-hasse
   (package
     (name "texlive-lie-hasse")