summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-11 21:18:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-11 22:28:22 +0100
commit71ce0b52901e49002502d220551dad21c07a7fed (patch)
tree33dcb463429a982ff5b62b89abca804720f9fb6c
parent2ecb5e7901ab9e826f8eb5ff21dbd84fb032c46f (diff)
downloadguix-71ce0b52901e49002502d220551dad21c07a7fed.tar.gz
gnu: fmt: Build shared library instead of static.
* gnu/packages/pretty-print.scm (fmt)[arguments]: New field.
* gnu/packages/networking.scm (fmt-restinio): Remove variable.
(restinio)[propagated-inputs]: Change from FMT-RESTINIO to FMT.
(opendht)[inputs]: Likewise.
-rw-r--r--gnu/packages/networking.scm10
-rw-r--r--gnu/packages/pretty-print.scm9
2 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e4190e98d4..cfa244c39b 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2523,12 +2523,6 @@ communication over HTTP.")
       (home-page "https://github.com/Corvusoft/restbed")
       (license license:agpl3+))))
 
-(define fmt-restinio
-  (package
-    (inherit fmt)
-    (arguments
-     '(#:configure-flags '("-DCMAKE_CXX_FLAGS=-fPIC")))))
-
 (define-public restinio
   (package
     (name "restinio")
@@ -2553,7 +2547,7 @@ communication over HTTP.")
        ("sobjectizer" ,sobjectizer)))
     (propagated-inputs
      `(("asio", asio)
-       ("fmt" ,fmt-restinio)
+       ("fmt" ,fmt)
        ("http-parser", http-parser)))
     (arguments
      `(#:configure-flags '("-DRESTINIO_INSTALL=on")
@@ -2592,7 +2586,7 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
        ("readline" ,readline)
        ("jsoncpp" ,jsoncpp)
        ("openssl" ,openssl)
-       ("fmt" ,fmt-restinio)))
+       ("fmt" ,fmt)))
     (propagated-inputs
      `(("argon2" ,argon2)  ; TODO: Needed for the pkg-config .pc file to work?
        ("msgpack" ,msgpack)))           ;included in several installed headers
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index cfe06a0be2..34d49938ac 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -174,6 +174,8 @@ different programming languages.")
                (base32
                 "0h148anbaqgch6n69pxsvs1c9wmykgd052wmzgdia7qpz8w6p8dl"))))
     (build-system cmake-build-system)
+    (arguments
+     '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
     (native-inputs
      `(("unzip" ,unzip)))
     (home-page "http://fmtlib.net/")
@@ -185,6 +187,13 @@ to @code{IOStreams}.")
     ;; The library is bsd-2, but documentation and tests include other licenses.
     (license (list bsd-2 bsd-3 psfl))))
 
+(define-public fmt-restinio
+  (hidden-package
+   (package/inherit
+    fmt
+    (arguments
+     '(#:configure-flags '("-DCMAKE_CXX_FLAGS=-fPIC"))))))
+
 (define-public source-highlight
   (package
     (name "source-highlight")