summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:27:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:50 +0200
commit721b2a46dde6bacab60a012766ddb8deb328f037 (patch)
tree217afc9050c0196fec020037abaec229505b6225
parentab0a27520a2cf8066394a479a44ccdf31d801259 (diff)
downloadguix-721b2a46dde6bacab60a012766ddb8deb328f037.tar.gz
gnu: Add texlive-karnaughmap.
* gnu/packages/tex.scm (texlive-karnaughmap): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aedb1778c1..b6c6505c99 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4272,6 +4272,27 @@ semi-automatically or manually.  Last but not least it contains commands for
 drawing implicants on top of the map.")
     (license license:cc-by-sa3.0)))
 
+(define-public texlive-karnaughmap
+  (package
+    (name "texlive-karnaughmap")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/karnaughmap/"
+                   "source/latex/karnaughmap/"
+                   "tex/latex/karnaughmap/")
+             (base32
+              "0wwgdcpv5chr7frnlf2j56yiwk5m28bixbv83p2h4f3jl10v5hwi")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/karnaughmap")
+    (synopsis "Typeset Karnaugh maps")
+    (description
+     "This package provides an easy to use interface to typeset Karnaugh maps
+using TikZ.  Though similar to the @code{karnaugh} macros, it provides
+a key-value system to customize Karnaugh maps and a proper LaTeX package.")
+    (license license:lppl1.2+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")