summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:25:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:45 +0200
commit767a401b2f253306b4a4693d067c1c34f85a05e0 (patch)
treee0a9aec2d5f6f2e0637b68928c0ce4b0309553b2
parent1c7add8a79f82f9784f5240c588ecec14fb299a9 (diff)
downloadguix-767a401b2f253306b4a4693d067c1c34f85a05e0.tar.gz
gnu: Add texlive-ibrackets.
* gnu/packages/tex.scm (texlive-ibrackets): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f5b0deb6f3..3091557a82 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4070,6 +4070,27 @@ adds a collection of useful @acronym{HEP, High Energy Physics} units to the
 existing SIunits set.")
     (license license:lppl)))
 
+(define-public texlive-ibrackets
+  (package
+    (name "texlive-ibrackets")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/ibrackets/"
+                   "source/latex/ibrackets/"
+                   "tex/latex/ibrackets/")
+             (base32
+              "0ipqh7z1v4l6fgbgkizn5v2g2l3b4n5zlmdaalj22ylgd2k25mv6")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ibrackets")
+    (synopsis "Intelligent brackets")
+    (description
+     "This small package provides a new definition of brackets @samp{[} and
+@samp{]} as active characters to get correct blank spaces in mathematical mode
+when using for open intervals.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")