summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-24 14:07:12 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:08:05 +0100
commit76997a0ddb2d7dde8d390470f8d28f2ea3b7d6d1 (patch)
tree45eea6bd99dab84c719eb1b2c026d4905c6d56c4
parent3e16291043b49f544a009da93bcb3bd04503df17 (diff)
downloadguix-76997a0ddb2d7dde8d390470f8d28f2ea3b7d6d1.tar.gz
gnu: Remove ocaml4.07-base64.
* gnu/packages/ocaml.scm (ocaml4.07-base64): Remove variable.
(ocaml-base64)[properties]: Remove variant.

Change-Id: Ibf92682e0d322e9d294c99f5532da2fe68a92f4a
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f47ccd8494..dd52189811 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4284,7 +4284,6 @@ multitude of other network protocols (FTP/SMTP/RTSP/etc).")
     (build-system dune-build-system)
     (native-inputs
      (list ocaml-alcotest ocaml-bos ocaml-rresult))
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-base64))))
     (home-page "https://github.com/mirage/ocaml-base64")
     (synopsis "Base64 encoding for OCaml")
     (description "Base64 is a group of similar binary-to-text encoding schemes
@@ -4292,25 +4291,6 @@ that represent binary data in an ASCII string format by translating it into a
 radix-64 representation.  It is specified in RFC 4648.")
     (license license:isc)))
 
-(define-public ocaml4.07-base64
-  (package-with-ocaml4.07
-    (package
-      (inherit ocaml-base64)
-      (version "3.2.0")
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/mirage/ocaml-base64")
-                       (commit (string-append "v" version))))
-                (file-name (git-file-name "ocaml-base64" version))
-                (sha256
-                 (base32
-                  "1ilw3zj0w6cq7i4pvr8m2kv5l5f2y9aldmv72drlwwns013b1gwy"))))
-      (arguments
-       ;; Tests are likely incompatible with our recent alcotest
-       `(#:tests? #f))
-      (properties '()))))
-
 (define-public ocamlify
   (package
     (name "ocamlify")