summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:32:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:00 +0200
commit7763c64407df186fcaec522140e1497ab8adb4b0 (patch)
tree320b11bfbedd6245cdef5c807ebd3d815f3875c8
parent4fe6970da3bdaa8f48dcbe9952eea62c8db7e299 (diff)
downloadguix-7763c64407df186fcaec522140e1497ab8adb4b0.tar.gz
gnu: Add texlive-mhchem.
* gnu/packages/tex.scm (texlive-mhchem): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 25def775ea..0bb2158ec0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4847,6 +4847,36 @@ interfaces for many programming languages, it also implements its own
 scripting language, called MGL, which can be used independently.")
     (license (list license:gpl3 license:cc-by-sa3.0))))
 
+(define-public texlive-mhchem
+  (package
+    (name "texlive-mhchem")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mhchem/" "tex/latex/mhchem/")
+             (base32
+              "1hmsl16l1vzhxy0iv8grbnpv83zffsrk6kzhgcaymdmigsv1i81b")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs
+     (list texlive-amsmath
+           texlive-chemgreek
+           texlive-graphics
+           texlive-l3kernel
+           texlive-l3packages
+           texlive-tools))
+    (home-page "https://ctan.org/pkg/mhchem")
+    (synopsis
+     "Typeset chemical formulae/equations and H and P statements")
+    (description
+     "The bundle provides three packages: The @code{mhchem} package provides
+commands for typesetting chemical molecular formulae and equations.  The
+@code{hpstatement} package provides commands for the official hazard
+statements and precautionary statements (H and P statements) that are used to
+label chemicals.  The @code{rsphrase} package provides commands for the
+official Risk and Safety (R and S) Phrases that are used to label chemicals.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")