summary refs log tree commit diff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:16 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:10 +0200
commit796b78d684670bea9bb10e5937688d30cc748259 (patch)
tree56d52052f2b4b2dfae120e0086c1dbbba16c0762
parent78bd62abaac7d8eb2dce6d8e50b60544843602b1 (diff)
downloadguix-796b78d684670bea9bb10e5937688d30cc748259.tar.gz
gnu: xdg-user-dirs: Drop docbook workaround.
* gnu/packages/freedesktop.scm (xdg-user-dirs)[arguments]: Remove.
[native-inputs]: Remove labels.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/freedesktop.scm27
1 files changed, 4 insertions, 23 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 36a925c951..5ec01ed4e8 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -2497,29 +2497,10 @@ Rendering Manager devices.")
                (base32 "13216b8rfkzak5k6bvpx6jvqv3cnbgpijnjwj8a8d3kq4cl0a1ra"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("docbook-xsl" ,docbook-xsl)
-       ("docbook-xml" ,docbook-xml-4.3)
-       ("xsltproc" ,libxslt)))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'build 'locate-catalog-files
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((xmldoc (string-append (assoc-ref inputs "docbook-xml")
-                                          "/xml/dtd/docbook"))
-                   (xsldoc (string-append (assoc-ref inputs "docbook-xsl")
-                                          "/xml/xsl/docbook-xsl-"
-                                          ,(package-version docbook-xsl))))
-               (for-each (lambda (file)
-                           (substitute* file
-                             (("http://.*/docbookx\\.dtd")
-                              (string-append xmldoc "/docbookx.dtd"))))
-                         (find-files "man" "\\.xml$"))
-               (substitute* "man/Makefile"
-                 (("http://.*/docbook\\.xsl")
-                  (string-append xsldoc "/manpages/docbook.xsl")))
-               #t))))))
+     (list gettext-minimal
+           docbook-xsl
+           docbook-xml-4.3
+           libxslt))
     (home-page "https://www.freedesktop.org/wiki/Software/xdg-user-dirs/")
     (synopsis "Tool to help manage \"well known\" user directories")
     (description "xdg-user-dirs is a tool to help manage \"well known\" user