summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-12 22:18:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-12 22:47:56 +0100
commit7d779142ab663f898aae316b12cee3b52840ec38 (patch)
tree9fd6a908be76a8807e79a9b5d9affff969e67387
parent262ab4b17cd75e51b60ee34e6303722b654d3e09 (diff)
downloadguix-7d779142ab663f898aae316b12cee3b52840ec38.tar.gz
gnu: Add r-rarpack.
* gnu/packages/cran.scm (r-rarpack): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 32505a1208..6d200d0768 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10999,3 +10999,27 @@ abstraction.  It includes Einstein and Riemann summing conventions, dragging,
 co- and contravariate indices, and parallel computations on sequences of
 tensors.")
     (license license:gpl2+)))
+
+(define-public r-rarpack
+  (package
+    (name "r-rarpack")
+    (version "0.11-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rARPACK" version))
+       (sha256
+        (base32
+         "12h2y46xcfldhjdmm960swgn9b23zvkj5vg2bi42s9qxwgi02d63"))))
+    (properties `((upstream-name . "rARPACK")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rspectra" ,r-rspectra)))
+    (home-page "https://github.com/yixuan/rARPACK")
+    (synopsis "Solvers for large scale eigenvalue and SVD problems")
+    (description
+     "This package was previously an R wrapper of the ARPACK library, and now
+a shell of the R package RSpectra, an R interface to the Spectra library for
+solving large scale eigenvalue/vector problems.  The current version of
+rARPACK simply imports and exports the functions provided by RSpectra.  New
+users of rARPACK are advised to switch to the RSpectra package.")
+    (license license:bsd-3)))