summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-06-06 22:15:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-06-07 09:14:04 +0300
commit7e7c8b253cc520812dacfb3a33427a992f56b74c (patch)
treee5dd9ba80cae09d06bcaab718e4b573e5719bf46
parent2660f99b5761d215555dc0f95a562ba68e4a0f77 (diff)
downloadguix-7e7c8b253cc520812dacfb3a33427a992f56b74c.tar.gz
gnu: python-flake8: Update to 4.0.1.
* gnu/packages/python-xyz.scm (python-flake8): Update to 4.0.1.
[source]: Remove snippet.
[arguments]: Respect tests?.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 56a3972703..b9af0d4a3f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10219,27 +10219,21 @@ cyclomatic complexity of Python source code.")
 (define-public python-flake8
   (package
     (name "python-flake8")
-    (version "3.9.2")
+    (version "4.0.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "flake8" version))
               (sha256
                (base32
-                "0sspgh2ph7bb5fmf49mrdhi7n5m421kfkxk1n0vn4akgg20q6lh7"))
-              (snippet
-               #~(begin
-                   (use-modules (guix build utils))
-                   (substitute* "setup.cfg"
-                     ;; Remove upper bound on pyflakes version.
-                     (("(pyflakes >=.*), .*" _ pyflakes)
-                      (string-append pyflakes "\n")))))))
+                "03c7mnk34wfz7a0m5zq0273y94awz69fy5iww8alh4a4v96h6vl0"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'check
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (add-installed-pythonpath inputs outputs)
-                      (invoke "pytest" "-v"))))))
+                    (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+                      (when tests?
+                        (add-installed-pythonpath inputs outputs)
+                        (invoke "pytest" "-v")))))))
     (propagated-inputs (list python-pycodestyle python-entrypoints
                              python-pyflakes python-mccabe))
     (native-inputs (list python-mock python-pytest))