summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-01 00:18:23 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-01 00:46:31 +0100
commit7fd9c40f602c2aae32772992d36866e25d15993f (patch)
treed74634663182e046ffe551f8f429bea28c472567
parentbbf9adf525091c5d7f267ed69cd73aa59b9c51b0 (diff)
downloadguix-7fd9c40f602c2aae32772992d36866e25d15993f.tar.gz
gnu: emacs-lice-el: Update to 0.3.
* gnu/packages/emacs-xyz.scm (emacs-lice-el): Update to 0.3.
-rw-r--r--gnu/packages/emacs-xyz.scm69
1 files changed, 34 insertions, 35 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index aa90958390..85aa8ac136 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21897,47 +21897,46 @@ Magit.")
     (license license:gpl3+)))
 
 (define-public emacs-lice-el
-  (let ((commit "482e58ab83fff86ed754b00be27b62a219597e7c"))
-    (package
-      (name "emacs-lice-el")
-      (version (git-version "0.2" "2" commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/buzztaiki/lice-el")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0yxkjyhfk8kpr8yqz54gdx6xwkj4s8bnbz60162jh12crj0bs5n7"))))
-      (build-system emacs-build-system)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-template-directory
-             (lambda* (#:key outputs #:allow-other-keys)
-               (chmod "lice.el" #o666)
-               (emacs-substitute-variables "lice.el"
-                 ("lice:system-template-directory"
-                  (string-append (assoc-ref outputs "out")
-                                 "/share/emacs-lice-el/template")))
-               #t))
-           (add-after 'install 'install-templates
-             (lambda* (#:key outputs #:allow-other-keys)
-               (copy-recursively
-                "template"
+  (package
+    (name "emacs-lice-el")
+    (version "0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/buzztaiki/lice-el")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "06plnrxj6kgnl9mjcbc48mgagpa60yyyyribwicmcgg9pgrs0wad"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-template-directory
+           (lambda* (#:key outputs #:allow-other-keys)
+             (chmod "lice.el" #o666)
+             (emacs-substitute-variables "lice.el"
+               ("lice:system-template-directory"
                 (string-append (assoc-ref outputs "out")
-                               "/share/emacs-lice-el/template"))
-               #t)))))
-      (home-page "https://github.com/buzztaiki/lice-el")
-      (synopsis "License and header template for Emacs")
-      (description "@code{lice.el} provides following features:
+                               "/share/emacs-lice-el/template")))
+             #t))
+         (add-after 'install 'install-templates
+           (lambda* (#:key outputs #:allow-other-keys)
+             (copy-recursively
+              "template"
+              (string-append (assoc-ref outputs "out")
+                             "/share/emacs-lice-el/template"))
+             #t)))))
+    (home-page "https://github.com/buzztaiki/lice-el")
+    (synopsis "License and header template for Emacs")
+    (description "@code{lice.el} provides following features:
 
 @itemize
 @item License template management.
 @item File header insertion.
 @end itemize\n")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-academic-phrases
   (let ((commit "0823ed8c24b26c32f909b896a469833ec4d7b656"))