summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 15:00:13 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:43 +0100
commit81a8d57d036ce98af523349c9c739a3b26c90206 (patch)
treed1332cdf61523e038d9742197194a66137309c27
parente86eb91206b4588ffc77b001b0d2b88c2411f583 (diff)
downloadguix-81a8d57d036ce98af523349c9c739a3b26c90206.tar.gz
gnu: Add go-go-uber-org-dig.
* gnu/packages/golang-xyz.scm (go-go-uber-org-dig): New variable.

Change-Id: I127569582dbf060b2870c8ac7f977a96e5ba9596
-rw-r--r--gnu/packages/golang-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 24aee155a7..13c23012cd 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3210,6 +3210,33 @@ similar string with weeks or days too.")
 CPU quota.")
     (license license:expat)))
 
+(define-public go-go-uber-org-dig
+  (package
+    (name "go-go-uber-org-dig")
+    (version "1.17.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/uber-go/dig")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "020dak2r0yykk6fkfwad2wbz73pjbbdkdamn0ir7xf2irxsmjakm"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.20
+      #:import-path "go.uber.org/dig"))
+    (native-inputs
+     (list go-github-com-stretchr-testify-next))
+    (home-page "https://pkg.go.dev/go.uber.org/dig")
+    (synopsis "Reflection based dependency injection toolkit for Golang")
+    (description
+     "Package @code{dig} provides a functionality to implement resolving
+object dependencies graph during the process startup.")
+    (license license:expat)))
+
 (define-public go-go-uber-org-zap
   (package
     (name "go-go-uber-org-zap")