summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-13 12:06:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-13 13:17:51 +0100
commit849350fbce49950348516f702a351cf7e0216af7 (patch)
tree3d9673c438250c5aba2aef7216ab6e3411cf7df8
parent704de8f5eeee67402648cc6624defa79600d1d75 (diff)
downloadguix-849350fbce49950348516f702a351cf7e0216af7.tar.gz
gnu: Add r-shinybs.
* gnu/packages/cran.scm (r-shinybs): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d6301f1a89..5b6546e51c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10923,6 +10923,33 @@ intersecting sets using a novel matrix design, along with visualizations of
 several common set, element and attribute related tasks.")
     (license license:expat)))
 
+;; This package includes a JavaScript file, which is not minified.  When
+;; upgrading please check that there are no new minified JavaScript files.
+(define-public r-shinybs
+  (package
+    (name "r-shinybs")
+    (version "0.61")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "shinyBS" version))
+       (sha256
+        (base32
+         "0rhim4mbp4x9vvm7xkmpl7mhb9qd1gr96cr4dv330v863ra2kgji"))))
+    (properties `((upstream-name . "shinyBS")))
+    (build-system r-build-system)
+    ;; The tests spawn Shiny browser apps.  They cannot be run
+    ;; non-interactively.
+    (arguments '(#:tests? #f))
+    (propagated-inputs
+     `(("r-htmltools" ,r-htmltools)
+       ("r-shiny" ,r-shiny)))
+    (home-page "https://ebailey78.github.io/shinyBS/")
+    (synopsis "Twitter Bootstrap components for Shiny")
+    (description
+     "This package adds additional Twitter Bootstrap components to Shiny.")
+    (license license:gpl3)))
+
 (define-public r-outliers
   (package
     (name "r-outliers")