summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:05:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:31 +0200
commit84cb690281a5024decde5268ccb6d246c2a6fcf4 (patch)
tree55c83bb76cba226fc2bade81670ca1b93d5cbc76
parent536bb5d67e2f15a253e321997742b06a223ce575 (diff)
downloadguix-84cb690281a5024decde5268ccb6d246c2a6fcf4.tar.gz
gnu: Add texlive-xargs.
* gnu/packages/tex.scm (texlive-xargs): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 583ed3aa95..d7ce4200cb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99967,6 +99967,36 @@ concepts of namespace and scope.  It also allows users to customize reference
 formats.")
     (license license:expat)))
 
+(define-public texlive-xargs
+  (package
+    (name "texlive-xargs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/xargs/" "source/latex/xargs/"
+                   "tex/latex/xargs/")
+             (base32
+              "1gbdnc1k819fncvnhzihx9q6qdxsrkpfjy47dh70bdwqf5klhqbh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (native-inputs
+     (list (texlive-updmap.cfg
+            (list texlive-etoolbox
+                  texlive-hypdoc
+                  texlive-lm
+                  texlive-microtype
+                  texlive-minitoc
+                  texlive-mparhack
+                  texlive-xkeyval))))
+    (home-page "https://ctan.org/pkg/xargs")
+    (synopsis "Define commands with many optional arguments")
+    (description
+     "The package provides extended versions of @code{\\newcommand} and related
+LaTeX commands, which allow easy and robust definition of macros with many
+optional arguments, using a clear and simple @code{xkeyval}-style syntax.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar