summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 13:08:38 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:26 +0800
commit855da38770809c799fc78666509d9d10e9cc0a93 (patch)
tree7cb92d3734d0c2b6762b9af5f9d0b09f32bf6046
parent9af1b6d55d0505c3228b31759732806e55a2e5d8 (diff)
downloadguix-855da38770809c799fc78666509d9d10e9cc0a93.tar.gz
gnu: Add kcrash-5.
* gnu/packages/kde-frameworks.scm (kcrash-5): New variable.

Change-Id: I33e8276a28626744be04b6aae60b98ec24bc213d
-rw-r--r--gnu/packages/kde-frameworks.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 3e86184149..9351b559f6 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2100,6 +2100,26 @@ localized country name to ISO 3166-1 alpha 2 code mapping and vice verca.
 application crashes.")
     (license license:lgpl2.1+)))
 
+(define-public kcrash-5
+  (package
+    (inherit kcrash)
+    (name "kcrash")
+    (version "5.116.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kde/stable/frameworks/"
+                    (version-major+minor version) "/"
+                    name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0rg8g50y44gq3hjl5fc36siyyq3czd2zrf4c70fspk33svwldlw1"))))
+    (native-inputs
+     (list extra-cmake-modules))
+    (inputs
+     (list kcoreaddons-5 kwindowsystem-5 qtx11extras))
+    (arguments '())))
+
 (define-public kdoctools
   (package
     (name "kdoctools")