summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-13 11:39:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-13 11:51:28 +0200
commit85df1a8631014d3e0c7907ddbea53f7a6c490d6b (patch)
treef3f3acd01e2a8f4281a84924e802492a7e8b11a4
parent0c6ade0be65ea91d62a5b4372648e711371b0f5c (diff)
downloadguix-85df1a8631014d3e0c7907ddbea53f7a6c490d6b.tar.gz
gnu: Add r-ggsci.
* gnu/packages/cran.scm (r-ggsci): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5d4af23227..bf4c8a413f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4190,3 +4190,26 @@ generating multiple logo plots, and aiding the visualisation with annotations.
 Sequence logos can easily be combined with other ggplot2 plots.")
     ;; Unspecified version of the LGPL.
     (license license:lgpl3+)))
+
+(define-public r-ggsci
+  (package
+    (name "r-ggsci")
+    (version "2.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggsci" version))
+       (sha256
+        (base32
+         "0g73x6grbka7ahjh6z23m3wrcifp5rdfdiasbl8lq4sp6rplxwaa"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)
+       ("r-scales" ,r-scales)))
+    (home-page "https://nanx.me/ggsci/")
+    (synopsis "Scientific journal and sci-fi themed color palettes for ggplot2")
+    (description
+     "This package provides a collection of ggplot2 color palettes inspired by
+plots in scientific journals, data visualization libraries, science fiction
+movies, and TV shows.")
+    (license license:gpl3)))