summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:14:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:03 +0200
commit875c58be7714b6f54aa545fd86a6fdc1a1f75368 (patch)
tree8cb55e3ac273d2d28f02730fa507072a878878a3
parentfe59ea88d770a05d75b0cd8617efcc7f8462e872 (diff)
downloadguix-875c58be7714b6f54aa545fd86a6fdc1a1f75368.tar.gz
gnu: Add texlive-esstix.
* gnu/packages/tex.scm (texlive-esstix): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb0519f8f0..048c663223 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11440,6 +11440,33 @@ by Michel Bovani.")
 describing relations between ordered pairs, using Metafont.")
     (license license:lppl1.3+)))
 
+(define-public texlive-esstix
+  (package
+    (name "texlive-esstix")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/esstix/"
+                   "fonts/afm/esstix/"
+                   "fonts/map/dvips/esstix/"
+                   "fonts/tfm/public/esstix/"
+                   "fonts/type1/public/esstix/"
+                   "fonts/vf/public/esstix/"
+                   "tex/latex/esstix/")
+             (base32
+              "1wfl7q6yx7pflzy402ldx7p3zw3xgvgvilrdzv7pm0w937a3qkm9")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/esstix")
+    (synopsis "PostScript versions of the ESSTIX, with macro support")
+    (description
+     "These fonts represent translation to PostScript Type 1 of the ESSTIX
+fonts.  ESSTIX seem to have been a precursor to the STIX project.  The
+accompanying virtual fonts with customized metrics and LaTeX support files
+allow their use as @code{calligraphic}, @code{fraktur} and
+@code{double-struck} (blackboard bold) in maths mode.")
+    (license license:silofl1.1)))
+
 (define-public texlive-euclideangeometry
   (package
     (name "texlive-euclideangeometry")