summary refs log tree commit diff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-08 13:34:12 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:26 +0800
commit8c0cead882990769c845b861b5f0038412b7a1cd (patch)
tree1800c8fbf7b9ef2030e3dbccb8a0fd518da5994e
parentc203f7312a83cca4923e8427a419ac933ff44dfc (diff)
downloadguix-8c0cead882990769c845b861b5f0038412b7a1cd.tar.gz
gnu: Remove kblog.
* gnu/packages/kde-pim.scm (kblog): Delete variable.

Change-Id: If2a4b44c9baddc0d02f43ce06b20351ca749a6f9
-rw-r--r--gnu/packages/kde-pim.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index f41494947e..a514a99f7f 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -550,40 +550,6 @@ NextCloud, Kolab, Google Contacts, Microsoft Exchange (EWS) or any standard
 CalDAV server.")
     (license (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
 
-(define-public kblog
-  (package
-    (name "kblog")
-    (version "20.04.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://kde/stable/release-service/" version
-                           "/src/kblog-" version ".tar.xz"))
-       (sha256
-        (base32 "1d5r9ivc1xmhkrz780xga87p84h7dnxjl981qap16gy37sxahcjr"))))
-    (build-system qt-build-system)
-    (native-inputs
-     (list extra-cmake-modules))
-    (inputs
-     (list kcalendarcore
-           kcoreaddons
-           ki18n
-           kio
-           kxmlrpcclient
-           qtbase-5
-           syndication))
-    ;; Note: Some tests take up to 90 sec.
-    (home-page "https://invent.kde.org/pim/kblog")
-    (synopsis "Client-side support library for web application remote blogging
-APIs")
-    (description "KBlog is a library for calling functions on Blogger 1.0,
-MetaWeblog, MovableType and GData compatible blogs.  It calls the APIs using
-KXmlRpcClient and Syndication.  It supports asynchronous sending and fetching
-of posts and, if supported on the server, multimedia files.  Almost every
-modern blogging web application that provides an XML data interface supports
-one of the APIs mentioned above.")
-    (license license:lgpl2.0+)))
-
 (define-public kaccounts-integration
   (package
     (name "kaccounts-integration")