summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:34:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:03 +0200
commit8d9f9d71e59f4fddb06c4913405f6bf996d0d0af (patch)
tree47721c92fdab13933b181207aa6acecce8a213ca
parent2d03e284604e64545b6c50d725f1fd17708444ea (diff)
downloadguix-8d9f9d71e59f4fddb06c4913405f6bf996d0d0af.tar.gz
gnu: Add texlive-se2thesis.
* gnu/packages/tex.scm (texlive-se2thesis): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 162c175ce4..9a6f4d4b44 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -27097,6 +27097,31 @@ typesetting diaries, journals or devotionals.")
      "This package provides a thesis template of Shandong University.")
     (license license:lppl1.3+)))
 
+(define-public texlive-se2thesis
+  (package
+    (name "texlive-se2thesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/se2thesis/"
+                   "source/latex/se2thesis/"
+                   "tex/latex/se2thesis/")
+             (base32
+              "0ixdj8klgj9i7hcrmwrxngyc5pgxpfkw3awkn5s0dcppz88rid1n")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/se2thesis")
+    (synopsis
+     "Thesis class for the Chair of Software Engineering II at the
+University of Passau, Germany")
+    (description
+     "The @code{se2thesis} bundle provides a document class for writing
+a theses with the Chair of Software Engineering II at the University of
+Passau, Germany.  The class is based on KOMA-Script classes.  While the class
+provides some basic settings, mostly regrading the type area, fonts, and the
+title page, it still provides large degrees of freedom to its users.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-serbian-apostrophe
   (package
     (name "texlive-serbian-apostrophe")