summary refs log tree commit diff
diff options
context:
space:
mode:
authorDariqq <dariqq@posteo.net>2024-10-06 08:33:20 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-22 00:27:49 +0200
commit91121714644264c2b7081588f07feb71610303cf (patch)
tree28152c4d4eec14d3cfda96106b06a72aa17e7dc4
parent81e0b5954f22293d30160375d8d6a212b6c0ee41 (diff)
downloadguix-91121714644264c2b7081588f07feb71610303cf.tar.gz
gnu: mozo: Wrap python and gi dependencies.
* gnu/packages/mate.scm (mozo)
[#:phases]: Add 'python-and-gi-wrap phase.
[inputs]: Add gtk+ and mate-panel.

Change-Id: I322878083101b5c05da53fe13092afa037e32736
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/mate.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 974c54bd27..1ab834b339 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -29,6 +29,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
@@ -1548,11 +1549,28 @@ used to bring up authentication dialogs.")
        (sha256
         (base32 "0929yk7g7103d18p400ysi19pqrxl3dyzg4l0mnw7a3azm7ri67y"))))
     (build-system glib-or-gtk-build-system)
+    (arguments
+     (list
+      #:imported-modules `((guix build python-build-system)
+                           ,@%glib-or-gtk-build-system-modules)
+      #:modules '((guix build utils)
+                  (guix build glib-or-gtk-build-system)
+                  ((guix build python-build-system) #:prefix python:))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'glib-or-gtk-wrap 'python-and-gi-wrap
+            (lambda* (#:key inputs outputs #:allow-other-keys)
+              (wrap-program (search-input-file outputs "bin/mozo")
+                `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")
+                                       ,(python:site-packages inputs outputs)))
+                `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
     (native-inputs
      (list pkg-config))
     (inputs
      (list gettext-minimal
+           gtk+
            mate-menus
+           mate-panel
            python
            python-pygobject))
     (home-page "https://mate-desktop.org/")