summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:23:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 00:35:38 +0100
commit915209cb7e968df8d4144d24ce97af9a70232d26 (patch)
treec7c3231611481da55f4e68b69723fe11e421d873
parent98822152796b3eedcd1abec4db5cfbfeaf478a18 (diff)
downloadguix-915209cb7e968df8d4144d24ce97af9a70232d26.tar.gz
gnu: go-github-com-jackpal-gateway: Move to golang-web.
* gnu/packages/syncthing.scm (go-github-com-jackpal-gateway): Move from
here ...
* gnu/packages/golang-web.scm: ... to here.

Change-Id: Ibc24eb85c76df4cea60749eaca55eb7ae7cb3cf5
-rw-r--r--gnu/packages/golang-web.scm23
-rw-r--r--gnu/packages/syncthing.scm22
2 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 90d7323e21..36bf7fe0cd 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1278,6 +1278,29 @@ used like a user interface for humans, to read and edit before passing the
 JSON data to the machine.")
     (license license:expat)))
 
+(define-public go-github-com-jackpal-gateway
+  (package
+    (name "go-github-com-jackpal-gateway")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jackpal/gateway")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1yms2dw4dnz4cvj9vhwh6193d50jhvn5awsp2g3a4lcc3sjrgd6m"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/jackpal/gateway"))
+    (home-page "https://github.com/jackpal/gateway")
+    (synopsis "Discover the address of a LAN gateway")
+    (description "@code{gateway} is a Go library for discovering the IP
+address of the default LAN gateway.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-jackpal-go-nat-pmp
   (package
     (name "go-github-com-jackpal-go-nat-pmp")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 04f735f876..021d66662a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -280,28 +280,6 @@ structs in the Go programming language.")
     (home-page "https://github.com/d4l3k/messagediff")
     (license expat)))
 
-(define-public go-github-com-jackpal-gateway
-  (package
-    (name "go-github-com-jackpal-gateway")
-    (version "1.0.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/jackpal/gateway")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1yms2dw4dnz4cvj9vhwh6193d50jhvn5awsp2g3a4lcc3sjrgd6m"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/jackpal/gateway"))
-    (synopsis "Discover the address of a LAN gateway")
-    (description "@code{gateway} is a Go library for discovering the IP
-address of the default LAN gateway.")
-    (home-page "https://github.com/jackpal/gateway")
-    (license bsd-3)))
-
 (define-public go-github-com-oschwald-geoip2-golang
   (package
     (name "go-github-com-oschwald-geoip2-golang")