summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 15:16:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-24 15:34:03 +0100
commit91d9e145e15241c20729a4f1fa43f3d662f6b806 (patch)
treec49e3b262fb6501c814c1203931fdab6433da9f4
parentd40c00c0f13ea8c715da093f3b36193baa2959e0 (diff)
downloadguix-91d9e145e15241c20729a4f1fa43f3d662f6b806.tar.gz
gnu: go-github-com-jackpal-go-nat-pmp: Move to golang-web.
gnu/packages/syncthing.scm (go-github-com-jackpal-go-nat-pmp): Move from
here ...
gnu/packages/golang-web.scm: ... to here.

Change-Id: Ib58a2f2d1f6bb279cd74d8460a7e02a5e4849c52
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/syncthing.scm23
2 files changed, 26 insertions, 24 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index e0f6af529b..b51fb85081 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,7 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2019, 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2019, 2020, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
@@ -1095,6 +1096,30 @@ used like a user interface for humans, to read and edit before passing the
 JSON data to the machine.")
     (license license:expat)))
 
+(define-public go-github-com-jackpal-go-nat-pmp
+  (package
+    (name "go-github-com-jackpal-go-nat-pmp")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jackpal/go-nat-pmp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1p2yrzfbkazc9nisr2iqjwzhb6q16zj6finyxxn2ikk7iiighl1g"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/jackpal/go-nat-pmp"))
+    (home-page "https://github.com/jackpal/go-nat-pmp")
+    (synopsis "Port mapping and discovery of external IP address")
+    (description
+     "This package provides a Go client for the NAT-PMP internet protocol for
+port mapping and discovering the external IP address of a firewall.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-jcmturner-dnsutils-v2
   (package
     (name "go-github-com-jcmturner-dnsutils-v2")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 366a5f0ebb..43199d4ad6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -213,29 +213,6 @@ notification area icon for Syncthing.  Supported Syncthing features:
 (define-public qsyncthingtray
   (deprecated-package "qsyncthingtray" syncthing-gtk))
 
-(define-public go-github-com-jackpal-go-nat-pmp
-  (package
-    (name "go-github-com-jackpal-go-nat-pmp")
-    (version "1.0.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/jackpal/go-nat-pmp")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1p2yrzfbkazc9nisr2iqjwzhb6q16zj6finyxxn2ikk7iiighl1g"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/jackpal/go-nat-pmp"))
-    (synopsis "Port mapping and discovery of external IP address")
-    (description "This package provides a Go client for the NAT-PMP internet
-protocol for port mapping and discovering the external IP address of a
-firewall.")
-    (home-page "https://github.com/jackpal/go-nat-pmp")
-    (license asl2.0)))
-
 (define-public go-github-com-audriusbutkevicius-recli
   (package
     (name "go-github-com-audriusbutkevicius-recli")