summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-26 00:05:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-26 00:06:44 +0100
commit92f4b6c121b9b73a3aefc7930ad7a91410583b62 (patch)
tree27c56899c61df53b9643b1d00e9b9ca7f558162f
parentd921b7eb09c4128e4826f0a9ef98ddae27224c71 (diff)
downloadguix-92f4b6c121b9b73a3aefc7930ad7a91410583b62.tar.gz
gnu: go-github-com-multiformats-go-multiaddr: Update to 0.12.3.
* gnu/packages/golang-web.scm (go-github-com-multiformats-go-multiaddr): Update to 0.12.3.
[propagated-inputs]: Add go-github-com-ipfs-go-cid,
go-github-com-multiformats-go-multibase,
go-github-com-multiformats-go-varint, and go-golang-org-x-exp.
[native-inputs]: Add go-github-com-stretchr-testify.

Change-Id: I5cc7f48155de57ea41ea6378cd7f61fe9bbb687d
-rw-r--r--gnu/packages/golang-web.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c3fd57bb55..979415e411 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2907,7 +2907,7 @@ presenting a small interface.")
 (define-public go-github-com-multiformats-go-multiaddr
   (package
     (name "go-github-com-multiformats-go-multiaddr")
-    (version "0.1.0")
+    (version "0.12.3")
     (source
      (origin
        (method git-fetch)
@@ -2916,13 +2916,19 @@ presenting a small interface.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0cdzlzh7cb1pj9mhq45va3r6gs6pcdfa9j7vdrqlv3zd6k3bxg39"))))
+        (base32 "1rn02yn7494r7ayn585bbsddprbn8wdccxs4n2k5dmll4dyd39mp"))))
     (build-system go-build-system)
     (arguments
      (list
       #:import-path "github.com/multiformats/go-multiaddr"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
     (propagated-inputs
-     (list go-github-com-multiformats-go-multihash))
+     (list go-github-com-ipfs-go-cid
+           go-github-com-multiformats-go-multibase
+           go-github-com-multiformats-go-varint
+           go-github-com-multiformats-go-multihash
+           go-golang-org-x-exp))
     (home-page "https://github.com/multiformats/go-multiaddr")
     (synopsis "Composable and future-proof network addresses")
     (description