summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:07:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:51 +0200
commit94578cde33833f6955e4ae52696ba967c60fdf87 (patch)
treecd258bfd4dd95bb15d3873783290ba55211de9ac
parente3e6dde662823730c0f42d418c6dff058d24f597 (diff)
downloadguix-94578cde33833f6955e4ae52696ba967c60fdf87.tar.gz
gnu: Add texlive-chessfss.
* gnu/packages/tex.scm (texlive-chessfss): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8b1db254c3..10c18aadcf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4259,6 +4259,32 @@ board.  It has a lot of options to place pieces on the board.  Using exotic
 pieces (e.g., for fairy chess) is possible.")
     (license license:lppl)))
 
+(define-public texlive-chessfss
+  (package
+    (name "texlive-chessfss")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/chessfss/"
+                   "fonts/enc/dvips/chessfss/"
+                   "source/latex/chessfss/"
+                   "tex/latex/chessfss/")
+             (base32
+              "1l51famz3zx9v4v0mdxwk51xhaidwgfplf268q2f1ipif9h6ma5d")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/chessfss")
+    (synopsis "Package to handle chess fonts")
+    (description
+     "This package offers commands to use and switch between chess fonts.
+It uses the LaTeX font selection scheme (nfss).  The package doesn't parse,
+format and print PGN input like e.g., the packages @code{skak} or
+@code{texmate}; the aim of the package is to offer writers of chess packages
+a bundle of commands for fonts, so that they don't have to implement all these
+commands for themselves.  A normal user can use the package to print
+e.g,. single chess symbols and simple diagrams.")
+    (license license:lppl)))
+
 (define-public texlive-chhaya
   (package
     (name "texlive-chhaya")