summary refs log tree commit diff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundation.xyz>2024-04-09 12:22:36 +0200
committerChristopher Baines <mail@cbaines.net>2024-04-15 10:14:06 +0100
commit949c3682b7e4ba29c47c1fd92aecbca815b19d68 (patch)
tree05ed1857130af1412ab7a4e918cc3b5c550c2810
parent94fa92cc8ebcaa7ea8a401d34fc9d5ed9bd3aa9e (diff)
downloadguix-949c3682b7e4ba29c47c1fd92aecbca815b19d68.tar.gz
gnu: coin3d: Use system expat.
* gnu/packages/graphics.scm (coin3d): Remove bundled expat and use the
system one.

Change-Id: Ief176e320b7f57c5c3f349f244ed7d76e54f8281
Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index f866318289..7f704c3e58 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1972,6 +1972,10 @@ or by subtracting one shape from the other.")
             (for-each delete-file
                       '("cfg/csubst.exe"
                         "cfg/wrapmsvc.exe"))
+            ;; Unbundle expat.
+            (delete-file-recursively "src/xml/expat")
+            (substitute* "src/xml/document.cpp"
+              (("expat/expat\\.h") "expat.h"))
             ;; Delete references to packaging tool cpack. Otherwise the build
             ;; fails with "add_subdirectory given source "cpack.d" which is not
             ;; an existing directory."
@@ -1981,12 +1985,13 @@ or by subtracting one shape from the other.")
     (arguments
      (list #:configure-flags
            #~(list "-DCOIN_BUILD_DOCUMENTATION_MAN=ON"
+                   "-DUSE_EXTERNAL_EXPAT=ON"
                    (string-append "-DBOOST_ROOT="
                                   #$(this-package-input "boost")))))
     (native-inputs
      (list doxygen graphviz))
     (inputs
-     (list boost freeglut glew))
+     (list boost expat freeglut glew))
     (home-page "https://github.com/coin3d/coin")
     (synopsis
      "High-level 3D visualization library with Open Inventor 2.1 API")