summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:06:37 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:35 +0200
commit94e76840040b34f12fb8093cec14b1d777bcf215 (patch)
tree4b181fc481cc08615fb583adf8bc9ae6d29251a7
parent04edfcf7debed4a1db8fe2eac5f5f08615c1d80d (diff)
downloadguix-94e76840040b34f12fb8093cec14b1d777bcf215.tar.gz
gnu: geo: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation.

* gnu/packages/geo.scm
(grass): Remove input labels and trailing #t.
[inputs]: Add bash-minimal.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Ic9d1942098cbfa1d71a81b1f7e0dea352850a4ce
-rw-r--r--gnu/packages/geo.scm69
1 files changed, 34 insertions, 35 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 3255f25d54..02cb6bfd5b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2780,39 +2780,40 @@ orienteering sport.")
           (base32 "1gpfbppfajc8d6b9alw9fdzgaa83w26kl6fff1395bc9gal215ms"))))
       (build-system gnu-build-system)
       (inputs
-       `(("bzip2" ,bzip2)
-         ("cairo" ,cairo)
-         ("fftw" ,fftw)
-         ("freetype" ,freetype)
-         ("gdal" ,gdal)
-         ("geos" ,geos)
-         ("glu" ,glu)
-         ("libpng" ,libpng)
-         ("libtiff" ,libtiff)
-         ("mesa" ,mesa)
-         ("mariadb-dev" ,mariadb "dev")
-         ("mariadb-lib" ,mariadb "lib")
-         ("netcdf" ,netcdf)
-         ("openblas" ,openblas)
-         ("perl" ,perl)
-         ("postgresql" ,postgresql)
-         ("proj" ,proj)
-         ("python" ,python)
-         ("python-dateutil" ,python-dateutil)
-         ("python-numpy" ,python-numpy)
-         ("python-wxpython" ,python-wxpython)
-         ("readline" ,readline)
-         ("sqlite" ,sqlite)
-         ("wxwidgets" ,wxwidgets)
-         ("zlib" ,zlib)
-         ("zstd" ,zstd "lib")))
+       (list bash-minimal
+             bzip2
+             cairo
+             fftw
+             freetype
+             gdal
+             geos
+             glu
+             libpng
+             libtiff
+             mesa
+             `(,mariadb "dev")
+             `(,mariadb "lib")
+             netcdf
+             openblas
+             perl
+             postgresql
+             proj
+             python
+             python-dateutil
+             python-numpy
+             python-wxpython
+             readline
+             sqlite
+             wxwidgets
+             zlib
+             `(,zstd "lib")))
       (native-inputs
-       `(("bash" ,bash-minimal)
-         ("bison" ,bison)
-         ("flex" ,flex)
-         ("pkg-config" ,pkg-config)))
+       (list bash-minimal
+             bison
+             flex
+             pkg-config))
       (arguments
-       `(#:tests? #f ; No tests
+       `(#:tests? #f                    ; No tests
          #:modules ((guix build gnu-build-system)
                     ((guix build python-build-system) #:prefix python:)
                     (guix build utils))
@@ -2870,16 +2871,14 @@ orienteering sport.")
                  (symlink (string-append dir "/include")
                           (string-append out "/include"))
                  (symlink (string-append dir "/lib")
-                          (string-append out "/lib")))
-               #t))
+                          (string-append out "/lib")))))
            (add-after 'install-links 'python:wrap
              (assoc-ref python:%standard-phases 'wrap))
            (add-after 'python:wrap 'wrap-with-python-interpreter
              (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out")))
                  (wrap-program (string-append out "/bin/" ,grassxx)
-                   `("GRASS_PYTHON" = (,(which "python3"))))
-                 #t))))))
+                   `("GRASS_PYTHON" = (,(which "python3"))))))))))
       (synopsis "GRASS Geographic Information System")
       (description
        "GRASS (Geographic Resources Analysis Support System), is a Geographic