summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-12 11:20:29 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:57 -0500
commit95aa068e44d585ba84f6b02add0b6b791b135f2e (patch)
treef82d4ffeb7d88cb3d876d543efae484268ce24cb
parent1c48820ed6d694ce2545b2ac68dcf252b35c27fe (diff)
downloadguix-95aa068e44d585ba84f6b02add0b6b791b135f2e.tar.gz
gnu: Add Test-Without-Module.
* gnu/packages/perl.scm (perl-test-without-module): New variable.
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 718b259dc6..6776048e2e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2358,6 +2358,27 @@ hooking into done_testing as well as via an END block.  You can declare a
 plan, or not, and things will still Just Work.")
     (license (package-license perl))))
 
+(define-public perl-test-without-module
+  (package
+    (name "perl-test-without-module")
+    (version "0.18")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CO/CORION/"
+                           "Test-Without-Module-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0zwc2dk5srd02j4p049w77m89iw5nbff381rmhcbaz8x2w5kdhz2"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Test-Without-Module")
+    (synopsis "Test fallback behaviour in absence of modules")
+    (description "This module allows you to deliberately hide modules from a
+program even though they are installed.  This is mostly useful for testing
+modules that have a fallback when a certain dependency module is not
+installed.")
+    (license (package-license perl))))
+
 (define-public perl-test-writevariants
   (package
     (name "perl-test-writevariants")