summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndrew Whatson <whatson@gmail.com>2020-06-15 12:12:00 +1000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-15 08:59:56 +0200
commit98366c991f409869773098b2eb73309fa961ed90 (patch)
tree3fe9680e4fc789b015420529a51980c8db4a2239
parent1afa2c5ca0c5904bd9de70a48dd7d0a6275d5d3f (diff)
downloadguix-98366c991f409869773098b2eb73309fa961ed90.tar.gz
gnu: Add emacs-flycheck-guile.
 * gnu/packages/emacs-xyz.scm (emacs-flycheck-guile): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b3235f7096..e32e1d627f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3938,6 +3938,31 @@ provides an easy way to find synonyms and antonyms for a given word (to avoid
 repetitions for example).")
     (license license:gpl3+)))
 
+(define-public emacs-flycheck-guile
+  (package
+    (name "emacs-flycheck-guile")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/flatwhatson/flycheck-guile")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "163pnsh6r6bral1jg0vqri54g6hygws21vis0zci4114yb3fhkm1"))))
+    (propagated-inputs
+     `(("emacs-flycheck" ,emacs-flycheck)
+       ("emacs-geiser" ,emacs-geiser)))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/flatwhatson/flycheck-guile")
+    (synopsis "GNU Guile support for Flycheck")
+    (description
+     "This package provides a Flycheck checker for GNU Guile using @code{guild
+compile}.")
+    (license license:gpl3+)))
+
 (define-public emacs-flycheck-rust
   (package
     (name "emacs-flycheck-rust")