summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-09 12:03:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-09 20:55:30 +0300
commit9a1abc1352b772e7062a170083344f4803280979 (patch)
tree4953c349387cfbd447a29f4de210496d412df763
parent9a4c57f55f644ccd52d0d810f1db04f8c85ad8b9 (diff)
downloadguix-9a1abc1352b772e7062a170083344f4803280979.tar.gz
gnu: netpbm: Fix build on powerpc-linux.
* gnu/packages/netpbm.scm (netpbm)[arguments]: Adjust the 'setup-check
phase to skip 2 tests when building for powerpc-linux.

Change-Id: Ie8f23bed0f5d442df3a19e227bbdc3a17fa77511
-rw-r--r--gnu/packages/netpbm.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index 489a3c7a43..ce00df9479 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,7 +33,8 @@
   #:use-module (guix build-system gnu)
   #:use-module ((guix licenses) #:select (gpl2))
   #:use-module (guix packages)
-  #:use-module (guix svn-download))
+  #:use-module (guix svn-download)
+  #:use-module (guix utils))
 
 (define-public netpbm
   (package
@@ -158,6 +160,12 @@
              (("pnmremap1.test") "")
              (("gif-roundtrip.test") "")
 
+             ;; These two tests fail on powerpc-linux.
+             ,@(if (target-ppc32?)
+                   `((("pbmtog3\\.test") "")
+                     (("g3-roundtrip\\.test") ""))
+                   '())
+
              ;; These two tests started failing in netpbm-10.78.3.
              (("jpeg-roundtrip.test") "")
              (("pbmtext.test") "")