summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 14:31:41 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:28:26 +0100
commit9bcb67166f7bb5ad2a3e62a90bfca076bb9fbded (patch)
treed70c09aa04d35bee7c95ec06a85ddc65766c8cc7
parentfe2a300eaa09b73dd14d3adf9e4bc4f668892f41 (diff)
downloadguix-9bcb67166f7bb5ad2a3e62a90bfca076bb9fbded.tar.gz
gnu: go-github-com-oschwald-maxminddb-golang: Update to 1.13.0.
* gnu/packages/golang-web.scm (go-github-com-oschwald-maxminddb-golang): Update to 1.13.0.

Change-Id: I8b718ddf8c064f6492d882b70713243cfb82f4e8
-rw-r--r--gnu/packages/golang-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index ce2276586b..b727a0165a 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1832,7 +1832,7 @@ which produce colorized output using github.com/fatih/color.")
 (define-public go-github-com-oschwald-maxminddb-golang
   (package
     (name "go-github-com-oschwald-maxminddb-golang")
-    (version "1.4.0")
+    (version "1.13.0")
     (source
      (origin
        (method git-fetch)
@@ -1841,14 +1841,15 @@ which produce colorized output using github.com/fatih/color.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "100wd5qv00pkcm6cb8c4x5gavc9jnn7drh6xrqh85hzci4rils66"))))
+        (base32 "1p0c10r6850znvarc9h3y0jlwika9qmq0ys7rmg2aj8x2cffz3z6"))))
     (build-system go-build-system)
-    (propagated-inputs
-     (list go-golang-org-x-sys))
     (arguments
      (list
+      #:go go-1.21
       #:tests? #f ; Requires some unpackaged software and test data
       #:import-path "github.com/oschwald/maxminddb-golang"))
+    (propagated-inputs
+     (list go-golang-org-x-sys))
     (home-page "https://github.com/oschwald/maxminddb-golang")
     (synopsis "MaxMind DB Reader for Go")
     (description