summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-18 10:53:12 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-18 11:53:28 +0300
commit9c98e144ff3ba2038b21c7d44edabc786bb99f8d (patch)
tree4027f0436204d5d86c7f68f69dca4199bd4ef54c
parent83598dafb971fda9206f14cf46d072e04e27fd43 (diff)
downloadguix-9c98e144ff3ba2038b21c7d44edabc786bb99f8d.tar.gz
gnu: font-gnu-unifont: Update to 15.1.01.
* gnu/packages/fonts.scm (font-gnu-unifont): Update to 15.1.01.
[source]: Adjust snippet to not remove non-existent precompiled files.
[arguments]: Disable parallel build.  Adjust custom 'install phase to
not duplicate actions from the Makefile.
-rw-r--r--gnu/packages/fonts.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c51679c273..404495f6e3 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -933,7 +933,7 @@ for use at smaller text sizes")))
 (define-public font-gnu-unifont
   (package
     (name "font-gnu-unifont")
-    (version "15.0.01")
+    (version "15.1.01")
     (source
      (origin
        (method url-fetch)
@@ -943,12 +943,11 @@ for use at smaller text sizes")))
              (string-append "mirror://gnu/unifont/unifont-"
                             version "/unifont-" version ".tar.gz")))
        (sha256
-        (base32 "1m9lfss6sbmcr0b6h7pxxmdl71j9dmnvk8idvxzylqrwpwjaj4bx"))
+        (base32 "1dydcqa2nvmnij5jzj10carrzssd3ar24i8zd18pk4zpl84l4pz1"))
        (snippet
         '(begin
            (use-modules (guix build utils))
-           (delete-file-recursively "font/precompiled")
-           (delete-file-recursively "hangul/precompiled")))))
+           (delete-file-recursively "font/precompiled")))))
     (build-system gnu-build-system)
     (outputs '("out"   ; TrueType/OpenType version
                "pcf"   ; PCF (bitmap) version
@@ -956,6 +955,7 @@ for use at smaller text sizes")))
                "bin")) ; Utilities to manipulate '.hex' format
     (arguments
      `(#:tests? #f          ; no check target
+       #:parallel-build? #f ; Race condition in the font Makefile
        #:make-flags
        (list (string-append "CC=" ,(cc-for-target))
              "BUILDFONT=TRUE")
@@ -977,20 +977,13 @@ for use at smaller text sizes")))
                    (psf (string-append (assoc-ref outputs "psf")
                                        "/share/consolefonts"))
                    (bin (assoc-ref outputs "bin")))
-              ;; This directory isn't created in fonts/Makefile.
-              (mkdir-p otf)
               (apply invoke "make" "install"
                      (string-append "PREFIX=" bin)
                      (string-append "TTFDEST=" ttf)
                      (string-append "OTFDEST=" otf)
                      (string-append "PCFDEST=" pcf)
                      (string-append "CONSOLEDEST=" psf)
-                     make-flags)
-              ;; Move Texinfo file to the right place.
-              (mkdir (string-append bin "/share/info"))
-              (invoke "gzip" "-9n" "doc/unifont.info")
-              (install-file "doc/unifont.info.gz"
-                            (string-append bin "/share/info"))))))))
+                     make-flags)))))))
     (native-inputs
      (list bdftopcf console-setup fontforge))
     (inputs