summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-10 14:46:38 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commit9d285c8bebc714bc757f889f1509932a8f485849 (patch)
treeaa5993b6b566493ac0f1b814be422035c88d6117
parent73c8574314295f32faa5424bc4623442d73e8444 (diff)
downloadguix-9d285c8bebc714bc757f889f1509932a8f485849.tar.gz
gnu: python-platformdirs: Update to 3.10.0.
* gnu/packages/python-xyz.scm (python-platformdirs): Update to 3.10.0.
[build-system]: Switch to PYPROJECT-BUILD-SYSTEM.
[native-inputs]: Add PYTHON-HATCHLING and PYTHON-HATCH-VCS.  Remove
PYTHON-SETUPTOOLS-SCM.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e800baa482..0426220ef2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31475,23 +31475,20 @@ compatible with a wide range of versions of the Stripe API.")
 (define-public python-platformdirs
   (package
     (name "python-platformdirs")
-    (version "2.4.1")
+    (version "3.10.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "platformdirs" version))
        (sha256
-        (base32 "1njz0h4iky8iglrb85cd07hpa3lp1a2dfr934dj65hxwzvfk61j4"))))
-    (build-system python-build-system)
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest" "-vv")))))))
+        (base32 "0vbzyw1k6wvg8gv9cg99ds5pri007c6rqx9668d6kk6pnbd9cmml"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-appdirs python-pytest python-pytest-mock
-           python-setuptools-scm))
+     (list python-appdirs
+           python-hatchling
+           python-hatch-vcs
+           python-pytest
+           python-pytest-mock))
     (home-page "https://github.com/platformdirs/platformdirs")
     (synopsis "Determine the appropriate platform-specific directories")
     (description "When writing applications, finding the right location to