summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2012-12-30 00:08:46 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-02 01:08:51 +0100
commit9dc6f288bfa00e2b16ab10a286d5dc41cedc8764 (patch)
treeebc5535026474d0b785160acd07ab17072484eff
parent5501e6b64fb6ea44d8d549b076fc13078c7d5b6c (diff)
downloadguix-9dc6f288bfa00e2b16ab10a286d5dc41cedc8764.tar.gz
distro: Add MIT Kerberos 5.
* distro/packages/mit-krb5.scm: New file.
* Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/mit-krb5.scm69
2 files changed, 70 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 30bf3f45d1..9d0047312b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,7 @@ MODULES =					\
   distro/packages/lsh.scm			\
   distro/packages/m4.scm			\
   distro/packages/make-bootstrap.scm		\
+  distro/packages/mit-krb5.scm			\
   distro/packages/multiprecision.scm		\
   distro/packages/nano.scm			\
   distro/packages/ncurses.scm			\
diff --git a/distro/packages/mit-krb5.scm b/distro/packages/mit-krb5.scm
new file mode 100644
index 0000000000..1737e9a42d
--- /dev/null
+++ b/distro/packages/mit-krb5.scm
@@ -0,0 +1,69 @@
+;;; Guix --- Nix package management from Guile.         -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Andreas Enge <andreas@enge.fr>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages mit-krb5)
+  #:use-module (distro)
+  #:use-module (distro packages bison)
+  #:use-module (distro packages perl)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public mit-krb5
+  (package
+   (name "mit-krb5")
+   (version "1.11")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "http://web.mit.edu/kerberos/www/dist/krb5/"
+                                version
+                                "/krb5-" version
+                                "-signed.tar"))
+            (sha256 (base32
+                     "0lc6lxb98qzg4x01lppq700vkr1ax9rld09znahrinwqnf9zndzy"))))
+   (build-system gnu-build-system)
+   (inputs `(("bison" ,bison)
+             ("perl" ,perl)
+             ))
+   (arguments
+    (lambda (system)
+      `(#:tests? #f
+        #:phases
+        (alist-replace
+         'unpack
+         (lambda* (#:key source #:allow-other-keys)
+          (system* "echo" source)
+          (let ((inner
+                 (substring source
+                            (string-index-right source #\k)
+                            (string-index-right source #\-))))
+           (system* "echo" inner)
+           (and (zero? (system* "tar" "xvf" source))
+                (zero? (system* "tar" "xvf" (string-append inner ".tar.gz")))
+                (chdir inner)
+                (chdir "src"))))
+          %standard-phases))))
+   (synopsis "MIT Kerberos 5")
+   (description
+    "Massachusetts Institute of Technology implementation of Kerberos.
+Kerberos is a network authentication protocol designed to provide strong
+authentication for client/server applications by using secret-key cryptography.")
+   (license (bsd-style "file://NOTICE"
+                       "See NOTICE in the distribution."))
+   (home-page "http://web.mit.edu/kerberos/")))