summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-14 18:51:32 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:31 +0200
commita10ff6fccc518d6a7d1070a28342931e5e78d87a (patch)
tree7a01c159480bd53504c0c7dbc4cb41cc7af80c52
parent2f7e32aa0fd0e279aac6e6e35a63cb482a050e93 (diff)
downloadguix-a10ff6fccc518d6a7d1070a28342931e5e78d87a.tar.gz
gnu: Add rust-half-1.3.
* gnu/packages/crates-io.scm (rust-half-1.3): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f20945454f..b2dcd1a8ed 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2584,6 +2584,30 @@ the regex engine it uses pluggable.")
     (description "Use PCRE2 with the grep crate.")
     (license (list license:expat license:unlicense))))
 
+(define-public rust-half-1.3
+  (package
+    (name "rust-half")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "half" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0diqajg3mgar511hxswl4kgqqz9a026yvn3103x5h2smknlc4lwk"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-serde" ,rust-serde-1.0))))
+    (home-page "https://github.com/starkat99/half-rs")
+    (synopsis "Half-precision floating point f16 type")
+    (description
+     "Half-precision floating point f16 type for Rust implementing the
+IEEE 754-2008 binary16 type.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-heapsize-0.4
   (package
     (name "rust-heapsize")