summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:20:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:28 +0200
commitaa5089ca880122375a6f3f5a2c5ef487f7f611b4 (patch)
tree2f08ad78a82e79694b45fce04416cb51f3158104
parent2ea41e2db84d2bf2882861c684eb996a170a9ff1 (diff)
downloadguix-aa5089ca880122375a6f3f5a2c5ef487f7f611b4.tar.gz
gnu: Add texlive-imakeidx.
* gnu/packages/tex.scm (texlive-imakeidx): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5286e94109..19795587f4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17433,6 +17433,31 @@ documents for the International Modal Analysis Conference.  The bundle
 provides a LaTeX package and a BibTeX style file.")
     (license license:gpl3+)))
 
+(define-public texlive-imakeidx
+  (package
+    (name "texlive-imakeidx")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/imakeidx/"
+                   "source/latex/imakeidx/"
+                   "tex/latex/imakeidx/")
+             (base32
+              "1s65kbzafx5q7519pbxjldb87flws0mgg76yxi7a5mgxrnkfy961")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/imakeidx")
+    (synopsis "Package for producing multiple indexes")
+    (description
+     "The package enables the user to produce and typeset one or more indexes
+simultaneously with a document.  The package is known to work in LaTeX
+documents processed with pdfLaTeX, XeLaTeX and LuaLaTeX.  If
+@command{makeindex} is used for processing the index entries, no particular
+setting up is needed.  When using Xindy or other programs, it is necessary to
+enable shell escape; shell escape is also needed if @command{splitindex} is
+used.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-imtekda
   (package
     (name "texlive-imtekda")