summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-06-18 17:42:25 +0800
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:10 +0200
commitaa8ef464147bceb4aa575b93901fa7162c7537b7 (patch)
treefa6354ad29eb4cfc4fcc9c447f219e8a172bf40e
parentdbd07ba11092b10df7156ba165713834154ace44 (diff)
downloadguix-aa8ef464147bceb4aa575b93901fa7162c7537b7.tar.gz
gnu: guile-proba: Fix build.
* gnu/packages/check.scm (guile-proba)[arguments]: Don't refer to nonexistent
'install' phase.

Change-Id: I2ef650c15f3f0d2640e746771667b20cfecb87ae
-rw-r--r--gnu/packages/check.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 0bd3a16a58..b95998b905 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -4088,7 +4088,7 @@ markers to simplify testing of asynchronous tornado applications.")
           (add-after 'build 'check
             (lambda _
               (invoke "guile" "proba.scm" "run" "tests")))
-          (add-after 'install 'install-wrapped-script
+          (add-after 'check 'install-wrapped-script
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (bin-dir (string-append out "/bin"))
@@ -4100,7 +4100,7 @@ markers to simplify testing of asynchronous tornado applications.")
                   `("GUILE_LOAD_PATH" prefix (,(getenv "GUILE_LOAD_PATH")))
                   `("GUILE_LOAD_COMPILED_PATH" prefix
                     (,(getenv "GUILE_LOAD_COMPILED_PATH")))))))
-          (add-after 'install 'install-manual
+          (add-after 'build-manual 'install-manual
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))
                      (info-dir (string-append out "/share/info")))