summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2024-09-21 23:48:00 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-26 10:08:27 +0100
commitae7fc060c0980e6276b0163ad76e2a125d1db9f3 (patch)
tree9aee99f0f32010aa9fbb99f2cf68b272f3a59a11
parent7c092d1e75d4079f1565bd02bd32544ec6c2279c (diff)
downloadguix-ae7fc060c0980e6276b0163ad76e2a125d1db9f3.tar.gz
gnu: python-altair: Update to 5.3.0.
* gnu/packages/statistics.scm (python-altair): Update to 5.3.0.
  [arguments]<#:test-flags>: Add failing tests, reorganize.

Reviewed-by: Steve George <steve@futurile.net>
Change-Id: I695e63e5395f40997ab59706240b8b059778b0ad
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/statistics.scm29
1 files changed, 21 insertions, 8 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 103a857317..b8de5a1d93 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -21,6 +21,7 @@
 ;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2108,7 +2109,7 @@ and Vega-Lite examples.")
 (define-public python-altair
   (package
     (name "python-altair")
-    (version "5.0.1")
+    (version "5.3.0")
     (source (origin
               (method git-fetch)        ; no tests in PyPI
               (uri (git-reference
@@ -2117,15 +2118,27 @@ and Vega-Lite examples.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1r74v5n51br9pjhxdzrr62cdgnwkapci93aifnl8dqmfpizfpd7d"))))
+                "1lx3pkphi36pljns6jjxhyn9fbrana8f1y6gcg4yca48nvwlfssl"))))
     (build-system pyproject-build-system)
     (arguments
-     ;; First two open an external connection.
-     ;; Last introduces a circular dependency on altair-viewer.
-     (list #:test-flags #~(list "-k" (string-append
-                                      "not test_from_and_to_json_roundtrip"
-                                      " and not test_render_examples_to_chart"
-                                      " and not test_save_html"))))
+     (list #:test-flags
+           ;; XXX: This test file requires hard to package python-anywidgets.
+           #~(list "--ignore=tests/test_jupyter_chart.py"
+                   "-k" (string-join
+                         (list
+                          ;; these tests open an external connection.
+                          "not test_from_and_to_json_roundtrip"
+                          "test_render_examples_to_chart"
+                          ;; introduces a circular dependency on altair-viewer.
+                          "not test_save_html"
+                          ;; these tests require the vl-convert vega compiler
+                          "test_vegalite_compiler"
+                          "test_to_dict_with_format_vega"
+                          "test_to_json_with_format_vega"
+                          "test_to_url"
+                          "test_renderer_with_none_embed_options"
+                          "test_jupyter_renderer_mimetype")
+                         " and not "))))
     (propagated-inputs (list python-jinja2
                              python-jsonschema
                              python-numpy