summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2021-01-18 19:27:43 +0300
committerLudovic Courtès <ludo@gnu.org>2021-02-02 11:05:43 +0100
commitaee9f696b1d9bd3c41dddc81997a4f0e73081cea (patch)
treeb0e512a8759e4060d6b1d178471b69098a28b1d7
parent84929062e3b6601dad5a8a97776c90ba4a4bf731 (diff)
downloadguix-aee9f696b1d9bd3c41dddc81997a4f0e73081cea.tar.gz
gnu: Add obs-wlrobs.
* gnu/packages/video.scm (obs-wlrobs): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/video.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ffa7e25023..4c555a5622 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -48,6 +48,7 @@
 ;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
 ;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -74,6 +75,7 @@
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix svn-download)
+  #:use-module (guix hg-download)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
@@ -3173,6 +3175,35 @@ and JACK.")
 OBS audio sources.")
     (license license:gpl2)))
 
+(define-public obs-wlrobs
+  (package
+    (name "obs-wlrobs")
+    (version "1.0")
+    (source
+      (origin
+        (method hg-fetch)
+        (uri (hg-reference
+              (url "https://hg.sr.ht/~scoopta/wlrobs")
+              (changeset (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1faiq2gdb7qis3m1hilm4pz8lkmkab75vzm608dbiazahhybf96p"))))
+    (build-system meson-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs `() )
+    (inputs `(("obs" ,obs)
+              ("libx11" ,libx11 "out")
+              ("wayland" ,wayland)
+              ("wayland-protocols" ,wayland-protocols)))
+    (home-page "https://hg.sr.ht/~scoopta/wlrobs")
+    (synopsis "OBS plugin for Wayland (wlroots) screen capture")
+    (description
+     "This OBS plugin allows you to capture the screen on wlroots-based
+Wayland compositors.")
+    (license license:gpl3+)))
+
 (define-public libvdpau
   (package
     (name "libvdpau")