summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 14:02:30 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2024-11-05 14:02:30 -0500
commitaf1a3382199297683c8a9c01a8348329c6ba958e (patch)
tree475d0f9f29cf94b881ccca30a5f0bb411f26cf2d
parent40b6729fd78ea53ac339257aea798d625e16894d (diff)
downloadguix-af1a3382199297683c8a9c01a8348329c6ba958e.tar.gz
gnu: Add wayland-protocols-next.
The previous version of wayland-protocols-next was removed in
72535be25ceaf11814204e57ad832d24c88e2d3b as wayland-protocols was updated to
the latest version at the time.  Now that there have been further updates to
wayland-protocols, restore wayland-protocols-next to the latest version for
use in any packages needing a newer wayland-protocols until wayland-protocols
itself is updated.

* gnu/packages/freedesktop.scm (wayland-protocols-next): New variable.

Change-Id: I5b9e3f55604e0b8eaa72ad341785353c32f97972
-rw-r--r--gnu/packages/freedesktop.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 51e77da3aa..bd34615e68 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -26,7 +26,7 @@
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
 ;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
 ;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
-;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022, 2024 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2021-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
@@ -1421,6 +1421,20 @@ protocol either in Wayland core, or some other protocol in wayland-protocols.")
         . "https://wayland.freedesktop.org/releases.html")))
     (license license:expat)))
 
+(define-public wayland-protocols-next
+  (package
+    (inherit wayland-protocols)
+    (name "wayland-protocols-next")
+    (version "1.38")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://gitlab.freedesktop.org/wayland/"
+                                  "wayland-protocols/-/releases/" version "/downloads/"
+                                  "wayland-protocols-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1ghxb0w7rbq3kdv9lhm1iwcjh6p3sx1gxb3crqh2p78m0ln2j5zz"))))))
+
 (define-public wayland-utils
   (package
     (name "wayland-utils")