summary refs log tree commit diff
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2024-07-07 11:54:28 +0200
committerAndreas Enge <andreas@enge.fr>2024-07-07 11:55:51 +0200
commitb141f45642fec0446970f3ba0a307086b4cb39b7 (patch)
tree88cd3d8c5b1d4f8d744f99a1e6d941f2af74e5b6
parentcf234330bdd703cf3da7fc5bc26d38d207201401 (diff)
downloadguix-b141f45642fec0446970f3ba0a307086b4cb39b7.tar.gz
gnu: Add wf-config.
* gnu/packages/wm.scm (wf-config): New variable.

Change-Id: Ie95333b92a8acb5f8b4f8e085e5ab35087bdc105
Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/wm.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 505ce09c1a..eecaaa2cf7 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -73,6 +73,7 @@
 ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
 ;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Wamm K. D. <jaft.r@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -145,6 +146,7 @@
   #:use-module (gnu packages logging)
   #:use-module (gnu packages lua)
   #:use-module (gnu packages man)
+  #:use-module (gnu packages maths)
   #:use-module (gnu packages mpd)
   #:use-module (gnu packages pciutils)
   #:use-module (gnu packages music)
@@ -3910,3 +3912,25 @@ configuration."))))
 for short) for X11 and Wayland, that goes to great lengths to be both CPU and
 battery efficient---polling is only done when absolutely necessary.")
     (license license:expat)))
+
+(define-public wf-config
+  (package
+    (name "wf-config")
+    (version "0.8.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url (string-append "https://github.com/WayfireWM/" name "/"))
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256 (base32
+                       "07x6dapv2xyg0cn44dd2faw5gpk7mwfpbkpld9kyiaa9d44362z1"))))
+    (build-system meson-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list glm libxml2 wlroots libevdev))
+    (home-page "https://github.com/WayfireWM/wf-config")
+    (synopsis "Library for managing configuration files for Wayfire")
+    (description "The package provides a library for managing the
+configuration files of Wayifre.  It can set key and mouse bindings,
+configure input, and customize Wayfire plugins.")
+    (license license:expat)))