summary refs log tree commit diff
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-08 02:52:53 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:46 +0200
commitb1f8862e2c5f2c05cdf1a5d7e475dcf9b2bd27c8 (patch)
tree88fb98c2e7ec3a109d2d4db855cd11da9e6c01c4
parent8d1932b47e94dac4fed4352ade21123f83728c8e (diff)
downloadguix-b1f8862e2c5f2c05cdf1a5d7e475dcf9b2bd27c8.tar.gz
gnu: Add rust-mach2-0.4.
* gnu/packages/crates-apple.scm (rust-mach2-0.4): New variable.

Change-Id: I20b06f1dfcb97c1cd9d9ac70dd47138746e2fc20
Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-apple.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 8ae341869d..806d0adc53 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2023 Steve George <steve@futurile.net>
 ;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -904,6 +905,28 @@ Mach 3.0 kernel that underlies OSX.")
 library")
   (license (list license:asl2.0 license:expat))))
 
+(define-public rust-mach2-0.4
+  (package
+    (name "rust-mach2")
+    (version "0.4.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "mach2" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "02gpyq89rcrqdbz4hgp5bpjas21dllxfc70jgw8vj0iaxg6mbf8r"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t ; compile_error!("mach requires macOS or iOS");
+       #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+    (home-page "https://github.com/JohnTitor/mach2")
+    (synopsis "Rust interface to the user-space API of the Mach 3.0 kernel")
+    (description
+     "This package provides a Rust interface to the user-space API of the Mach
+3.0 kernel that underlies OSX.")
+    (license (list license:bsd-2 license:expat license:asl2.0))))
+
 (define-public rust-metal-0.18
   (package
     (name "rust-metal")