summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:35:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:04 +0200
commitb2a6477a292a8b2e37c7d49801980fa7659744be (patch)
tree138cbf43ed9f8c118e0ff852507dcf6f2954e76f
parent1c84638285b918638fb1ebbcb9bd1a298fa82679 (diff)
downloadguix-b2a6477a292a8b2e37c7d49801980fa7659744be.tar.gz
gnu: Add texlive-nicematrix.
* gnu/packages/tex.scm (texlive-nicematrix): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b61925e02c..8366f42982 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5095,6 +5095,31 @@ physics at the University of Wurzburg as a collection of macros and predefined
 environments for quickly creating nice mathematical documents.")
     (license license:lppl1.3+)))
 
+(define-public texlive-nicematrix
+  (package
+    (name "texlive-nicematrix")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/nicematrix/"
+                   "source/latex/nicematrix/"
+                   "tex/latex/nicematrix/")
+             (base32
+              "0pvl6dj152n38phk8vpknhk253r8vdkm64wg55zk6fa4d4a158fy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/nicematrix")
+    (synopsis "Improve the typesetting of mathematical matrices with PGF")
+    (description
+     "This package is based on the package @code{array}.  It creates PGF/TikZ
+nodes under the cells of the array and uses these nodes to provide
+functionalities to construct tabulars, arrays and matrices.  Among the
+features, it provides: continuous dotted lines for the mathematical matrices;
+exterior rows and columns (so-called border matrices); control of the width of
+the columns; tools to color rows and columns with a good PDF result; blocks of
+cells; etc.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")